community.general.icx_config (0.1.1) — module

Manage configuration sections of Ruckus ICX 7000 series switches

Authors: Ruckus Wireless (@Commscope)

preview | supported by community

Install collection

Install with ansible-galaxy collection install community.general:==0.1.1


Add to requirements.yml

  collections:
    - name: community.general
      version: 0.1.1

Description

Ruckus ICX configurations use a simple block indent file syntax for segmenting configuration into sections. This module provides an implementation for working with ICX configuration sections in a deterministic way.

Usage examples

  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: configure top level configuration
  icx_config:
    lines: hostname {{ inventory_hostname }}
  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: configure interface settings
  icx_config:
    lines:
      - port-name test string
      - ip address 172.31.1.1 255.255.255.0
    parents: interface ethernet 1/1/2
  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: configure ip helpers on multiple interfaces
  icx_config:
    lines:
      - ip helper-address 172.26.1.10
      - ip helper-address 172.26.3.8
    parents: "{{ item }}"
  with_items:
    - interface ethernet 1/1/2
    - interface ethernet 1/1/3
  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: load new acl into device
  icx_config:
    lines:
      - permit ip host 192.0.2.1 any log
      - permit ip host 192.0.2.2 any log
      - permit ip host 192.0.2.3 any log
      - permit ip host 192.0.2.4 any log
    parents: ip access-list extended test
    before: no ip access-list extended test
    match: exact
  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: check the running-config against master config
  icx_config:
    diff_against: intended
    intended_config: "{{ lookup('file', 'master.cfg') }}"
  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: check the configuration against the running-config
  icx_config:
    diff_against: startup
    diff_ignore_lines:
      - ntp clock .*
  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: for idempotency, use full-form commands
  icx_config:
    lines:
      # - en
      - enable
    # parents: int eth1/0/11
    parents: interface ethernet 1/1/2
  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
# Set boot image based on comparison to a group_var (version) and the version
# that is returned from the `icx_facts` module
- name: SETTING BOOT IMAGE
  icx_config:
    lines:
      - no boot system
      - boot system flash bootflash:{{new_image}}
    host: "{{ inventory_hostname }}"
  when: ansible_net_version != version
  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: render template onto an ICX device
  icx_config:
    backup: yes
    src: "{{ lookup('file', 'config.j2') }}"

Inputs

    
src:
    description:
    - Specifies the source path to the file that contains the configuration or configuration
      template to load.  The path to the source file can either be the full path on the
      Ansible control host or a relative path from the playbook or role root directory.  This
      argument is mutually exclusive with I(lines), I(parents).
    type: str

after:
    description:
    - The ordered set of commands to append to the end of the command stack if a change
      needs to be made.  Just like with I(before) this allows the playbook designer to
      append a set of commands to be executed after the command set.
    type: list

lines:
    aliases:
    - commands
    description:
    - The ordered set of commands that should be configured in the section.  The commands
      must be the exact same commands as found in the device running-config.  Be sure
      to note the configuration command syntax as some commands are automatically modified
      by the device config parser.
    type: list

match:
    choices:
    - line
    - strict
    - exact
    - none
    default: line
    description:
    - Instructs the module on the way to perform the matching of the set of commands against
      the current device config.  If match is set to I(line), commands are matched line
      by line.  If match is set to I(strict), command lines are matched with respect to
      position.  If match is set to I(exact), command lines must be an equal match.  Finally,
      if match is set to I(none), the module will not attempt to compare the source configuration
      with the running configuration on the remote device.
    type: str

backup:
    default: 'no'
    description:
    - This argument will cause the module to create a full backup of the current C(running-config)
      from the remote device before any changes are made.  The backup file is written
      to the C(backup) folder in the playbook root directory or role root directory, if
      playbook is part of an ansible role. If the directory does not exist, it is created.
    type: bool

before:
    description:
    - The ordered set of commands to push on to the command stack if a change needs to
      be made.  This allows the playbook designer the opportunity to perform configuration
      commands prior to pushing any changes without affecting how the set of commands
      are matched against the system.
    type: list

parents:
    description:
    - The ordered set of parents that uniquely identify the section or hierarchy the commands
      should be checked against.  If the parents argument is omitted, the commands are
      checked against the set of top level or global commands.
    type: list

replace:
    choices:
    - line
    - block
    default: line
    description:
    - Instructs the module on the way to perform the configuration on the device.  If
      the replace argument is set to I(line) then the modified lines are pushed to the
      device in configuration mode.  If the replace argument is set to I(block) then the
      entire command block is pushed to the device in configuration mode if any line is
      not correct.
    type: str

defaults:
    default: 'no'
    description:
    - This argument specifies whether or not to collect all defaults when getting the
      remote device running config.  When enabled, the module will get the current config
      by issuing the command C(show running-config all).
    type: bool

save_when:
    choices:
    - always
    - never
    - modified
    - changed
    default: never
    description:
    - When changes are made to the device running-configuration, the changes are not copied
      to non-volatile storage by default.  Using this argument will change that before.  If
      the argument is set to I(always), then the running-config will always be copied
      to the start-up configuration and the I(modified) flag will always be set to True.  If
      the argument is set to I(modified), then the running-config will only be copied
      to the start-up configuration if it has changed since the last save to configuration.  If
      the argument is set to I(never), the running-config will never be copied to the
      configuration.  If the argument is set to I(changed), then the running-config will
      only be copied to the configuration if the task has made a change.
    type: str

diff_against:
    choices:
    - running
    - startup
    - intended
    description:
    - When using the C(ansible-playbook --diff) command line argument the module can generate
      diffs against different sources.
    - When this option is configure as I(startup), the module will return the diff of
      the running-config against the configuration.
    - When this option is configured as I(intended), the module will return the diff of
      the running-config against the configuration provided in the C(intended_config)
      argument.
    - When this option is configured as I(running), the module will return the before
      and after diff of the running-config with respect to any changes made to the device
      configuration.
    type: str

running_config:
    aliases:
    - config
    description:
    - The module, by default, will connect to the remote device and retrieve the current
      running-config to use as a base for comparing against the contents of source.  There
      are times when it is not desirable to have the task get the current running-config
      for every task in a playbook.  The I(running_config) argument allows the implementer
      to pass in the configuration to use as the base config for comparison.
    type: str

intended_config:
    description:
    - The C(intended_config) provides the master configuration that the node should conform
      to and is used to check the final running-config against.   This argument will not
      modify any settings on the remote device and is strictly used to check the compliance
      of the current device's configuration against.  When specifying this argument, the
      task should also modify the C(diff_against) value and set it to I(intended).
    type: str

diff_ignore_lines:
    description:
    - Use this argument to specify one or more lines that should be ignored during the
      diff.  This is used for lines in the configuration that are automatically updated
      by the system.  This argument takes a list of regular expressions or exact line
      matches.
    type: list

multiline_delimiter:
    default: '@'
    description:
    - This argument is used when pushing a multiline configuration element to the ICX
      device.  It specifies the character to use as the delimiting character.  This only
      applies to the configuration action.
    type: str

Outputs

backup_path:
  description: The full path to the backup file
  returned: when backup is yes
  sample: /playbooks/ansible/backup/icx_config.2016-07-16@22:28:34
  type: str
commands:
  description: The set of commands that will be pushed to the remote device
  returned: always
  sample:
  - hostname foo
  - router ospf 1
  - router-id 192.0.2.1
  type: list
updates:
  description: The set of commands that will be pushed to the remote device
  returned: always
  sample:
  - hostname foo
  - router ospf 1
  - router-id 192.0.2.1
  type: list