community.general.aix_lvg (8.5.0) — module

Manage LVM volume groups on AIX

Authors: Kairo Araujo (@kairoaraujo)

Install collection

Install with ansible-galaxy collection install community.general:==8.5.0


Add to requirements.yml

  collections:
    - name: community.general
      version: 8.5.0

Description

This module creates, removes or resize volume groups on AIX LVM.

Usage examples

  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: Create a volume group datavg
  community.general.aix_lvg:
    vg: datavg
    pp_size: 128
    vg_type: scalable
    state: present
  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: Removing a volume group datavg
  community.general.aix_lvg:
    vg: datavg
    state: absent
  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: Extending rootvg
  community.general.aix_lvg:
    vg: rootvg
    pvs: hdisk1
    state: present
  • Success
    Steampunk Spotter scan finished with no errors, warnings or hints.
- name: Reducing rootvg
  community.general.aix_lvg:
    vg: rootvg
    pvs: hdisk1
    state: absent

Inputs

    
vg:
    description:
    - The name of the volume group.
    required: true
    type: str

pvs:
    description:
    - List of comma-separated devices to use as physical devices in this volume group.
    - Required when creating or extending (V(present) state) the volume group.
    - If not informed reducing (V(absent) state) the volume group will be removed.
    elements: str
    type: list

force:
    default: false
    description:
    - Force volume group creation.
    type: bool

state:
    choices:
    - absent
    - present
    - varyoff
    - varyon
    default: present
    description:
    - Control if the volume group exists and volume group AIX state varyonvg V(varyon)
      or varyoffvg V(varyoff).
    type: str

pp_size:
    description:
    - The size of the physical partition in megabytes.
    type: int

vg_type:
    choices:
    - big
    - normal
    - scalable
    default: normal
    description:
    - The type of the volume group.
    type: str